Spoiler-View Deck Editor

Site Updates forum

Posted on March 9, 2018, 12:50 p.m. by abby315

In case you didn't see on our FB page, supporters can now beta-test our Spoiler View Deck Editor by clicking the banner at the top of the deck editor page. (If you're a supporter and you don't see this banner, use the contact form to let us know!)

We're hoping to roll it out to upgraded members soon, and then when we're happy with the functionality we'll release it to all users.

Please leave any feedback on the new feature here! Thanks :)

Suns_Champion says... #2

Looks very cool.

Are you going to be adding the deck description editing there too?

March 9, 2018 4:58 p.m.

yeaGO says... #3

Suns_Champion i was thinking it was just an area to be tutoring and tinkering. is there some reason you would want description editing over there?

March 10, 2018 12:39 a.m.

Suns_Champion says... #4

yeaGO Just curious really, though I do like having everything in one place. But that's just me :)

I guess I figured it would eventually replace the current deck editor? I dunno, jumped to conclusions.

Anyway it's got a good look and I love the level of customization. Like with the display, card sizes, sorting by type etc. Very nice.

March 10, 2018 1:02 a.m.

yeaGO says... #5

hmm... i was thinking about shoving a lot of the deck form over to more of like a 'settings' page. i want to put live changing charts and stuff on the new editor, so that would be a whole lot of busyness... considerations welcome of course

March 10, 2018 1:18 a.m.

eienshi09 says... #7

So... is it actually going to be replacing the current editor? Because I really like the simplicity of a text field I can just copy and paste my lists into. The new system is nice, but I wouldn't take it over a text field. If it's planned to just be an addition, then that'd be great for visualizing a deck during the construction process. but sometimes, you just want to paste a list and go.

Also, I'm probably missing something but how do I create custom categories in the new editor?

March 10, 2018 2:49 a.m.

yeaGO says... #8

text field is an alternate view that should never be out of sync, i don't think. don't worry, text field will always be a respected input (and output).

March 10, 2018 6:11 a.m.

yeaGO says... #9

eienshi09 for now, custom cats should just be done via the ordinary deck form until we can figure out the best way to add them to that interface

March 11, 2018 6:07 p.m.

Suns_Champion says... #10

yeaGO, abby315 glitch report for the new editor!

I'm in the new editor adjusting the number of Plains in my deck from 10 to 9. I save and continue editing. Everything seems okay.

Then I go to look at my deck, and I see I have 2 different sets of plains, and that I now have 110 cards in the deck.

I go back into the normal editor and see that the only difference is that the 9 plains have the (RIX) on them.

So the editor added 9 Plains and the card I replaced 1 Plains with, but kept the 10 Plains I originally had.

Otherwise the new editor works very smoothly! Very easy to search cards, and them to whichever board I want, and make easy swaps! I love love love the option to display the full card thumbnails! That helps us visual learners(and art appreciators) so much! Good luck!

March 15, 2018 1:04 p.m.

yeaGO says... #11

Folks, new update! Some bug fixes, some new perks for mobile editing. Give it a spin!

March 22, 2018 12:58 p.m.

Rexbolt says... #12

I'm having trouble saving changes I've made to the deck after I apply any filter. If I click "arrange by: color" and then delete a card, I get problem with saving message "Request failed with status code 404".

The same thing happens in the legacy board. As long as I don't apply a filter it has no problem saving changes, but as soon as I arrange by color, type, custom group, or anything it will no longer save changes.

March 26, 2018 8:09 p.m.

shroom_dude says... #13

When in the board deck editor I cannot save changes a message pops up saying there was a problem while attempting to save: Request failed with status code 404.

April 2, 2018 12:10 p.m.

yeaGO says... #14

shroom_dude very strange... could you screen shot that?

April 2, 2018 4:55 p.m.

shroom_dude says... #15

How do I do that?

April 2, 2018 7:16 p.m.

yeaGO says... #16

shroom_dude hmm i don't know what operating system you have and all that, you should google it... are you still getting this error?

April 3, 2018 12:16 a.m.

shroom_dude says... #17

I know how to take a screenshot I just don't know how to post it using the image hyperlink.

April 3, 2018 5:28 p.m.

shroom_dude says... #18

I now know it wasn't working because I was on the 2018 deck editor and I was saving it twice it didn't like that because there wasn't anything new the second time around. I still don't know how to post screenshots however.

April 3, 2018 5:32 p.m.

midgetman664 says... #19

The new Edit board feature is terrible. When i use that feature its because i want to see my whole deck in a convient manner to make cuts/adds. the new system is complicated and requires way to much scrolling. Trying to look at an EDH deck is horrible. Really Really prefer the old version. The old version gve me all the info in a consise manner. I can instantly see how many artifacts/lands/ect i have, i can easily adjust the number of each card in the deck, when i hover over a card it pops up. the new system has me makes finding all that information a hassle

April 7, 2018 8:10 p.m.

pesmerga87 says... #20

Agreed the new Edit Board for Decks is horrible... The old way was much easier to work with and actually made the editing decks manageable.

Is this new way to allow mobile users functionality? If so, I really don't see the point. This literally handicaps every user on the site, so that a small percentage of users can have functionality to a feature they probably use as an add on.

May 10, 2018 2:42 p.m.

yeaGO says... #21

Looking for another round of feedback here after making some changes based on the above comments. Thanks!

May 25, 2018 4:14 a.m.

Also, can we have an option to use the version 1 Spoiler View? My netbook never had issues using Spoiler View until today.

July 17, 2018 12:40 p.m.

DerektheRed says... #23

yeaGO - Is this forum still active? (asking only bc last update was in May)

Used the new editor again today (hadn't tried it in a while), and wanted to provide feedback. I really dislike the way the new editor alters card text in the old one. I wouldn't use it again for this reason. For example:

1. It removed * Need: X * from my maybeboard, which I just added in response to messages that the acquireboard is going away. Now I have to do it all over again...

2. It appended every single card in the deck with an edition. Which is fine... Half of them are wrong, which is a little annoying but I don't really care. Mostly I find it distracting; I use custom categories a lot and when it also has the edition it's visually cluttered. I know the site needs it to render the card, but it would be great if it could be 'turned off' (made invisible) to the user.

Thanks for all your work on the site!

July 18, 2018 3:26 a.m.

Duncan_D0nu1s says... #24

Please Fix:

cards not popping up when hovered over on other peoples decks, Clicking on each card is seriously annoying

Editing decks.... I can't edit anything right now unless I just made the deck and never closed the tab. When I go back I log in and can't actually access anything

September 13, 2018 10:03 a.m.

BobSMASH says... #25

Hi there! Thanks for the updates, and I'm really enjoying the new editor. I appreciate all the thought and hard work that you must put in.

I just wanted to let you know of a bug that I don't see listed here.

when using the "Wrench" icon on a card, I can only use it once, then it doesn't respond again.

So, If I have 4 Fatal Pushes, and I click the wrench icon to delete 2 copies, it will work exactly as expected. However, If I then go to a different card, say... Llanowar Elves, and click the wrench icon, the pop-up menu doesn't open. This is consistent across two different machines, using the most current version of Chrome, on win 10 pro 64.

Saving and continuing doesn't fix it, but saving and then coming back to the editor does.

I also have experienced the issue that was described by Suns_Champion, where changing the set of a land will create a duplicate set of lands.

Thanks again!

September 27, 2018 12:31 a.m.

Please login to comment