Unable to edit decks

TappedOut forum

Posted on Sept. 7, 2023, 4:26 p.m. by Adamamtios

Hello there,

just a simple 'bug' report I guess. As of today, I'm simply unable to edit my own decks. I'm logged in but it doesn't show the 'old' or 'new' edit mode, that should be show over the 'playtest' button.

Does anyone else have a similar problem?

Thank you very much in advance for any sort of help or suggestion!

yeaGO says... #2

sorry about that. we are working through a temporary display bug. let me know if it seems to work okay on your phone vs desktop and vice verse.

for the time being, you can edit the url manually and throw "/update/" at the end of the url to access the edit function. we will have this cleared up very soon.

September 7, 2023 4:29 p.m.

Starliner says... #3

I have the same problem. It is consistant on Mobile and PC, I tried changing browsers and had the same issue.

September 8, 2023 8:57 a.m.

yeaGO says... #4

Can you paste me the link of a particular deck for me to try some things

September 8, 2023 9:09 a.m.

Starliner says... #5

The problem is persistant across every deck on my profile, here is my most recent decklist: https://tappedout.net/mtg-decks/fairy-nuff/

In addition I just noticed I am unable to preview cards when hovering over them with the mouse. This is the same for each browser I tried chrome/firefox/edge on both PC and Mobile.

September 8, 2023 9:25 a.m.

Adamamtios says... #6

This would be my deck - but it's set on private, so I don't know if you see it. https://tappedout.net/mtg-decks/lathril-tempting-draining-elf-tribal/?cb=1693675691

September 8, 2023 4:31 p.m.

cristianodb says... #7

I have exactly the same problem as the people before. "Edit" button not appearing, no card preview when hovering over them, no color pie chart. It happens to all my decks.

September 8, 2023 5:46 p.m.

Rafnika_EDH says... #8

Found this thread through googling because Im having the same problem. Currently using the /update url addition to edit what I need to edit. Glad to hear its a known bug and not an issue with my account or internet cache. Will remain patient, thank you for the work on the site =)

September 8, 2023 7:49 p.m.

yeaGO says... #9

Does this seem fixed?

September 8, 2023 9:45 p.m.

Friso says... #10

I also have the same issue for my deck https://tappedout.net/mtg-decks/isle-of-lieutenants/

I tried refreshing after disabling cache and deleting cookies, but still had it afterwards.

September 9, 2023 4:56 a.m.

Starliner says... #11

Still not fixed for me.

September 9, 2023 9:06 a.m.

Same problem, 4 days running. Only on my phone’s browser. I reset my device/browser, logged out/in. Still missing edit, deckcycle and upvote buttons.

September 9, 2023 10:11 a.m.

shadowganon says... #13

I also am having the same issue and it occurs across mobile and desktop browser.

September 9, 2023 11:20 a.m.

Sonicron says... #14

Sad to say I have the exact same problem as the last few commentors. No edit button, no card previews, no color pie chart.

September 9, 2023 4:17 p.m.

TCK_Green says... #15

Quick workaround - as people have mentioned above, adding /update/ to the deck URL will take you to the basic editing page. If you want to use the 'Live Edit' feature then /board-update-2019/ is what you need. If you're not yeaGO then don't feel the need to read on! :)

@yeaGO - to add to this, four of the five icons in the top right navbar (inventory/notifications/messages/profile - everything except search) are also invisible from the decklist page but work fine from everywhere else I've tested on the site. I've done some basic investigation through Chrome's Developer Console and it shows that these buttons have the class name 'state-authenticated' added (which aren't there if you view them from other site pages), and manually removing this attribute makes the icons re-appear; I'm guessing that something has broken in the backend which is keeping these hidden. Similarly, the divs for the buttons on the sidebar ('col-sm-3 sidebar' > 'btn-group') have the extra class name 'state-owner' added, and manually removing this makes the two buttons reappear. Also similarly, the 'Deckcycle' and 'Feature' buttons aren't visible under 'hidden-xs' > 'btn-block' are because of the 'state-cycle' and 'state-authenticated' attributes (which might be why they're not in the 'visible-xs' list?), but I'm not sure why the pie charts ('combined-chart'/'type-chart'/'curve-chart') aren't appearing; the HTML is simply showing those divs as empty. You're also on your own with card not previewing from the deck pages though - they seem to be working fine from the Forum and card discussion pages (e.g. https://tappedout.net/mtg-card/wastes/), I can't work out why they're not working on the deck pages themselves.

(Update - I've just spotted that the Comments section is also broken which also seems to be a 'state-authenticated' issue.)

Hopefully the brief investigation above should be help determine the root cause for at least the missing buttons, but let me know if screenshots or similar would be helpful :) thanks again for TappedOut, it's a really great tool/resource!

September 10, 2023 7:30 p.m.

yeaGO says... #16

Thank you very much. What happens if you visit a broken page but add a cache busting get variable such as ?nocache=hello

September 10, 2023 8:49 p.m.

TCK_Green says... #17

Sorry for not getting back to you last night, UK hours and a long day means this is my first laptop reopen since my last message :)

I wish I could tell you what 'nocache=hello' might do to a broken page, but (un)fortunately they're all working again (tested multiple devices and browsers)! I had a quick check for the 'state-authenticated'/etc tags and they're no longer present, so it seems that the deck edit pages are once again behaving as per the rest of TappedOut for me. Did you manage to solve the issue then (or have I just become not helpful for further investigation)?

September 11, 2023 4:43 p.m.

Sonicron says... #18

That did the trick! Now the deck page displays as it should. What is that indicative of - a serverside problem, or something wacked-out on my end?

September 11, 2023 4:57 p.m.

yeaGO says... #19

Adblock :/

September 11, 2023 5:07 p.m.

Sonicron says... #20

Interesting to know, I hadn't realized. I whitelisted the site now, thanks for the heads-up!

September 11, 2023 6:20 p.m.

yeaGO says... #21

Adblock only updates their code when we do major updates and its extra confusing who or what is causing the problem.

September 13, 2023 11:37 p.m.

Please login to comment