New card alters don't seem to work

TappedOut forum

Posted on June 29, 2019, 6:22 a.m. by P_D_Ace


I recently tried for the first time to add my own alters. The uploading seems to have worked but the art doesn't show up in if I try to show it:

Tymna the Weaver for me does not display the art I added. While it does for arts that where already there:

Tymna the Weaver is shown perfectly fine.

Is the adding of new alters broken or is this an other sort of glitch?

yeaGO says... #2

Fixed for your account

June 29, 2019 11:15 a.m.

Randomsome1 says... #3

hi yeaGO, I am having the same problem. Can you help? I tried uploading the Japanese alters for a couple Planeswalkers ( Ral, Storm Conduit and Arlinn, Voice of the Pack ) a few months ago.

June 30, 2019 2:31 p.m.

yeaGO says... #4


June 30, 2019 2:47 p.m.

Jubilation says... #5

I've also had this problem for quite some time. Can you do your magic for me too, yeaGO?

June 30, 2019 10:38 p.m.

Nemy_Nem says... #6

Mind if i hop in on this? my alters dont show up either

July 1, 2019 3:18 a.m.

Please login to comment