Importing inventory error: "Error in line 1564"

TappedOut forum

Posted on July 30, 2018, 10:51 a.m. by thechristophershow

I'm trying to import my inventory from a CSV file created by Deckbox. When I save it on TappedOut, though, I keep getting this error message: "Invalid CSV file: Error in line 1564."

My CSV file, when I open it in Notepad to view it, is only like...I don't know, 40 lines tall, and each line is really long. How do I find line 1564? And why would there be an error when I made the CSV from Deckbox and didn't tamper with it at all afterwards?

yeaGO says... #2

Link to it from Google Docs or something

July 30, 2018 11:04 a.m.

I don't know how to make it a spreadsheet, though, so the lines aren't numbered here.

July 30, 2018 11:26 a.m.

Okay, I loaded it into a spreadsheet and discovered that line 1564 has nothing on it; 1563 is the final line. Don't know what to do with this information, though.

July 30, 2018 11:29 a.m.

yeaGO says... #5

sorry, you'll have to link to a spreadsheet version for help

July 30, 2018 1:33 p.m.

Here's the spreadsheet:

July 30, 2018 2:43 p.m.

As you can see in the spreadsheet above, there IS no row 1564, so how can there be an error in that row?

July 30, 2018 2:43 p.m.

Any ideas?

July 31, 2018 9:24 a.m.


August 1, 2018 10:43 a.m.

yeaGO says... #10

That spreadsheet is not formatted correctly. Please try to upload and link your original file somewhere

August 1, 2018 11:53 a.m.

Hmm. Where do I upload CSV files then so that I can link you to it?

I made that spreadsheet by opening the CSV file in Notepad, copying everything, and pasting it into the spreadsheet. Is there a better way to do it?

August 1, 2018 3:48 p.m.

yeaGO says... #12


August 1, 2018 3:50 p.m.

Okay, great, here it is:

August 1, 2018 5:40 p.m.

yeaGO says... #14

Seems like only some rows don't have the same amount of columns.... Maybe it's an error with their output format but it's very strange

August 1, 2018 5:48 p.m.

Hmm. But it says the error is in line 1564, a line that doesn't exist. I tried opening the CSV in Notepad and removing any extra spaces that might be occurring after line 1563, but there was nothing extra after that. Guess I just can't upload my inventory. Bah, that sucks.

August 2, 2018 9:12 a.m.

yeaGO says... #16

All bets are off with those columns looking like they are. Sort that out somehow or report it to them and try again

August 2, 2018 10:16 a.m.

I've even tried selecting the box "Ignore errors," but that doesn't work--it doesn't ignore the errors. Is there a bug in that "ignore errors" feature, you think?

August 7, 2018 10 p.m.

yeaGO says... #18

You should just send them that csv so they can fix whatever is broken with their export

August 8, 2018 8:54 p.m.

Please login to comment